WordPressとPHP

WordPressでサイトを構築した当時のサーバー側のPHPは確かVersion4くらいだと思います。
現在のPHPはVersion7.1、WordPressはこまめにアップデートされ対応している様ですが、プラグインツールの更新が停止しているものもあります。
半年程度更新されていないと新しいPHPに対応出来ず、動作しなくなるプラグインも多々あります。
WordPressもプラグイン、テーマ(表示テーマ)もアップデートがあると、管理画面に表示され、アップデートを推奨しています。
先日はテーマのアップデートをしたところ、サイトが表示されないアクシデントに見舞われました。
そのために同じテーマを使ったテスト用のサイトを構築し、まずは試験をしてからアップデートをしています。
プラグクインはWordPress本体にない便利な機能の追加のために導入しているのですが、こちらも曲者で、サーバー側のPHPバージョンに対応出来ていないものは使えません。
先ほどスマホからメール送信で投稿しましたが、今までのプラグインが対応出来ていないので、違うプラグインを探して導入しました。


コメントは受け付けていません